Komplettes Thema anzeigen 13.05.2013, 03:27
lornconner Abwesend
Dabei seit: 05.05.2013
Wohnort: -

Betreff: Re: Helfen, dass Indiana Jones und der Turm von Babel-Arbeit für ein English User?
Yes, I suppose I didn't explain that very well.

I had figured out that the Uninstall option for Indy3d only deregistered the SDB file, and figured that the proper method of removal was just to remove the game directories and files.

In trying to troubleshoot yesterday so much, the exact sequence of events has gotten muddled in my mind, but I'll try to describe to you what I *think* I did as best as I can remember.

1. After you had given me the Indy3d.sdb trick, I tried it and verified that it worked - the game ran beautifully and finally allowed me to save and load games without issue. This was from a base install that was only from the disks and your installer.

2. After verifying that this worked, I resolved to try and make an ISO image of my disks and mount them to see if I could play without the CD's. I found that I could not use the mounted images because the installation of the game was expecting the game files in the D:\ drive (My CD-ROM drive) and not the E:\ drive (which was where the virtual mounted image was located.) I manually removed the files. It might be here that things began to go wrong...my memory gets fuzzy, so I'm not sure if it was here, or after step 3.

3. After removing the installed copy of the game, I mounted the images I had created from my CD's, ran your replacement installer using the mounted images as source, and verified that I could load the game and it wouldn't prompt me for the disk.

4. I *think* at this point I played using the mounted images and everything was working fine. I know at some point I managed to load the game, quicksave, quickload, standard save, and standard load, and play all the way through the Canyonlands without issue. I made it to the start of Babylon, saved my game and exited. It was only AFTER exiting the game that all of my problems began anew.

The thing is, I can't remember if I succesfully played through that first level from the disk based installation, or after the image based installation. Technically, it shouldn't matter because the images should be exact copies of the intsallation disks, but something definitely had to change. I'm nearly certain that I succesfully played through that first level after I had removed my initial installation and after installing from images - that's why I was so excited.

In the gloom of troubleshooting since, the details have gotten fuzzy, though.

Here's what I know for sure:

1. Since the problems began, it's almost like how things were *before* you gave me the Indy3d.sdb fix. The game will crash 100% of the time if not running in compatibility mode. This is true whether launching from Jones3d.exe or Indy3d.exe in the Resource directory.

2. I can get the game to load *sometimes* by running in compatability mode - most succesful seems to be running as XP SP2, as administrator. Even this is hit or miss. Most of the time the game will crash when loading into the Canyonlands. Other times it will let me in, and will allow me to quicksave. Sometimes it will allow me to attempt to save a game, but it will almost always (80%?) crash at this point and do a hard hang - nothing but opening the Task Manager and killing the process will return control. Other times it will allow me to save the game. In all cases, loading a game (either via quickload or standard load) will crash to Desktop, and usually prevent me from launching the game again.

3. In those cases where the game does crash to Desktop the failure message is usually:

Problem signature:
Problem Event Name:    APPCRASH
Application Name:    Indy3d.exe
Application Version:
Application Timestamp:    3891bb91
Fault Module Name:    ntdll.dll
Fault Module Version:    6.1.7601.17725
Fault Module Timestamp:    4ec49b8f
Exception Code:    c0000005
Exception Offset:    00033ab3
OS Version:    6.1.7601.
Locale ID:    1033
Additional Information 1:    17ff
Additional Information 2:    17ffdeb5129ceb50b256f4116ffc6cf8
Additional Information 3:    b318
Additional Information 4:    b31806e551bac47803b723fee24aa1a2

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:

Oftnetime this will happen on the map loading screen into the Canyonlands, other times it will be after attempting to save or load.

There was one case where I got a message indicating it was a DirectInput error, but that was a one-off. I have not seen that message again.

Since these troubles began, I've tried mulitple corrections - uninstalling the Indy3d.sdb from the control panel, then manually removing the files; reintalling with your installer from the original game disks and not the mounted ISO's and repeating the Indy3d.sdb trick, repeating the uninstall and removal of game files; repeating the process and installing to a different directory; removing the files again and trying to install with Mark Useggers solution, then uninstalling and reattempting your installation method, and finally going through the registry and removing any entry having anything to do with "Infernal", "indy3d" or "jones3d" and then repeating the installation.

In all cases, the results have been the same.

The only thing that I can tell for absolutely sure is that the problems began after I succesfully completed the one level, saved my game, and exited. I had done nothing to change game performance after that - I'm just not sure what changed, and why I now can't negate whatever that change was.

Hope this information is helpful...if there's more you'd like me to capture, let me know and I'll do anything in my power to do so!